[Swift-user] first.swift issues

Zhao Zhang zhaozhang at uchicago.edu
Fri May 29 13:20:15 CDT 2009

Hi, Alex

I tried the swift in your home dir, assuming that is the one you are 
using. It works for me.
[zzhang at communicado amoore2]$ export PATH=/home/amoore2/swift-0.9/bin:$PATH
[zzhang at communicado amoore2]$ which swift
[zzhang at communicado amoore2]$ cd 
[zzhang at communicado examples]$ swift first.swift
Swift 0.9 swift-r2860 cog-r2388

RunID: 20090529-1318-ada6yjqb
Final status:  Finished successfully:1


Alex Moore wrote:
> Following the quick start guide to install swift on my CI account.
> When I try execute: swift first.swift I get the following message:
> "-Xmx256m not understood. Ignoring
> log4j:ERROR Error occurred while converting date.
> java.lan.IllegalArgumentExcepion: Illegal pattern character at
> java.text.SimpleDateFormat.format(java.util.Date, ..."
> It continues on for at least another page. This happens when I log in
> on both login.ci.uchicago.edu and communicado.ci.uchicago.edu. I tried
> deleting and reinstalling as well. I'm using swift-0.9
> Also, the first.swift file in package is different from the one in the
> swift tutorial. In swift-0.9, first.swift starts off with:
> type messagefile;
> app (messagefile t) greeting () {
>     echo "Hello, world!"......
> While the swift tutorial has:
> type messagefile;
> (messagefile t) greeting () {
>    app { echo "Hello, world!"......
> I changed first.swift to what was listed in the swift tutorial, and I
> got the same error message. Thank for your help.
> -Alex Moore
> _______________________________________________
> Swift-user mailing list
> Swift-user at ci.uchicago.edu
> http://mail.ci.uchicago.edu/mailman/listinfo/swift-user

More information about the Swift-user mailing list