[Swift-user] first.swift issues

Alex Moore amoore2 at uchicago.edu
Fri May 29 13:09:30 CDT 2009

Following the quick start guide to install swift on my CI account.
When I try execute: swift first.swift I get the following message:
"-Xmx256m not understood. Ignoring
log4j:ERROR Error occurred while converting date.
java.lan.IllegalArgumentExcepion: Illegal pattern character at
java.text.SimpleDateFormat.format(java.util.Date, ..."

It continues on for at least another page. This happens when I log in
on both login.ci.uchicago.edu and communicado.ci.uchicago.edu. I tried
deleting and reinstalling as well. I'm using swift-0.9

Also, the first.swift file in package is different from the one in the
swift tutorial. In swift-0.9, first.swift starts off with:

type messagefile;

app (messagefile t) greeting () {
    echo "Hello, world!"......

While the swift tutorial has:

type messagefile;

(messagefile t) greeting () {
   app { echo "Hello, world!"......

I changed first.swift to what was listed in the swift tutorial, and I
got the same error message. Thank for your help.
-Alex Moore

More information about the Swift-user mailing list