[petsc-users] Downloaded superlu_dist could not be used. Please check install in $PREFIX

Satish Balay balay at mcs.anl.gov
Tue Jan 18 23:48:04 CST 2022


This is with superlu-dist-7.1.1 [not master branch]


Executing: mpifort  -o /tmp/petsc-UYa6A8/config.compilers/conftest  -fopenmp -fopenmp  -I$PREFIX/include -fPIC -O3  -fopenmp /tmp/petsc-UYa6A8/config.compilers/conftest.o /tmp/petsc-UYa6A8/config.compilers/confc.o  -Wl,-rpath,$PREFIX/lib -L$PREFIX/lib -lsuperlu_dist -lpthread -Wl,-rpath,$PREFIX/lib -L$PREFIX/lib -lparmetis -Wl,-rpath,$PREFIX/lib -L$PREFIX/lib -lmetis -Wl,-rpath,$PREFIX/lib -L$PREFIX/lib -lflapack -Wl,-rpath,$PREFIX/lib -L$PREFIX/lib -lfblas -lm -Wl,-rpath,$BUILD_PREFIX/lib -L$BUILD_PREFIX/lib -lstdc++ -ldl -lmpifort -lmpi -lgfortran -lm -Wl,-rpath,$BUILD_PREFIX/lib/gcc/x86_64-conda-linux-gnu/9.3.0 -L$BUILD_PREFIX/lib/gcc/x86_64-conda-linux-gnu/9.3.0 -Wl,-rpath,$BUILD_PREFIX/lib/gcc -L$BUILD_PREFIX/lib/gcc -Wl,-rpath,$BUILD_PREFIX/x86_64-conda-linux-gnu/lib -L$BUILD_PREFIX/x86_64-conda-linux-gnu/lib -Wl,-rpath,$BUILD_PREFIX/lib -lgfortran -lm -lgcc_s -lquadmath -lrt -lquadmath -lstdc++ -ldl
Possible ERROR while running linker:
$BUILD_PREFIX/bin/../lib/gcc/x86_64-conda-linux-gnu/9.3.0/../../../../x86_64-conda-linux-gnu/bin/ld: warning: libmpicxx.so.12, needed by $PREFIX/lib/libsuperlu_dist.so, not found (try using -rpath or -rpath-link)

I don't really understand why this error comes up [as with shared libraries we should be able to link with -lsuperlu_dist - without having to link with libmpicxx.so.12

What do you get for:

ldd $PREFIX/lib/libstdc++.so

BTW: is configure.log modified to replace realpaths with $PREFIX $BUILD_PREFIX etc?

Can you try additional configure option LIBS=-lmpicxx and see if that works around this problem?


On Tue, 18 Jan 2022, Xiaoye S. Li wrote:

> There was a merge error in the master branch. I fixed it today. Not sure
> whether that's causing your problem.   Can you try now?
> Sherry
> On Mon, Jan 17, 2022 at 11:55 AM Fande Kong <fdkong.jd at gmail.com> wrote:
> > I am trying to port PETSc-3.16.3 to the MOOSE ecosystem. I got an error
> > that PETSc could not build  superlu_dist.  The log file was attached.
> >
> > PETSc-3.15.x worked correctly in the same environment.
> >
> > Thanks,
> > Fande
> >

More information about the petsc-users mailing list