Lisandro Dalcin dalcinl at gmail.com
Tue Sep 11 04:53:35 CDT 2018

If the plan is to eventually have a family of sympletic integrators, then I
think this is a really bad name.

We should follow the pattern elsewhere, and have a main TSSYMPLECTIC type,
and subtypes TSSYMPLECTICBASIC etc, and in command line we ask for -ts_type
sympletic -ts_sympletic_type basic.

Or, if there are no plans to have a family, then why to name it BASIC in
the first place?

PS: Not an expert in the field, feel free to hammer me about my ignorance.

Lisandro Dalcin
Research Scientist
Computer, Electrical and Mathematical Sciences & Engineering (CEMSE)
Extreme Computing Research Center (ECRC)
King Abdullah University of Science and Technology (KAUST)

4700 King Abdullah University of Science and Technology
al-Khawarizmi Bldg (Bldg 1), Office # 0109
Thuwal 23955-6900, Kingdom of Saudi Arabia

Office Phone: +966 12 808-0459
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-dev/attachments/20180911/bf00fb17/attachment.html>

More information about the petsc-dev mailing list