Zhang, Hong hongzhang at anl.gov
Tue Sep 11 09:29:36 CDT 2018

A few related discussions can be found at https://bitbucket.org/petsc/petsc/pull-requests/1108/rename-bsi-to-symplectic/diff

In addition, what we have in PETSc now is "Basic Symplectic Integrators" as introduced in Ernst Hairer's article https://www.unige.ch/~hairer/poly_geoint/week2.pdf .

Other types of symplectic methods such as symplectic Runge-Kutta use different tableaus and cannot be implemented in the same framework as the basic one. So when naming this particular type of symplectic methods, we think it is better to be specific than general.


On Sep 11, 2018, at 4:53 AM, Lisandro Dalcin <dalcinl at gmail.com<mailto:dalcinl at gmail.com>> wrote:

If the plan is to eventually have a family of sympletic integrators, then I think this is a really bad name.

We should follow the pattern elsewhere, and have a main TSSYMPLECTIC type, and subtypes TSSYMPLECTICBASIC etc, and in command line we ask for -ts_type sympletic -ts_sympletic_type basic.

Or, if there are no plans to have a family, then why to name it BASIC in the first place?

PS: Not an expert in the field, feel free to hammer me about my ignorance.

Lisandro Dalcin
Research Scientist
Computer, Electrical and Mathematical Sciences & Engineering (CEMSE)
Extreme Computing Research Center (ECRC)
King Abdullah University of Science and Technology (KAUST)

4700 King Abdullah University of Science and Technology
al-Khawarizmi Bldg (Bldg 1), Office # 0109
Thuwal 23955-6900, Kingdom of Saudi Arabia

Office Phone: +966 12 808-0459

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-dev/attachments/20180911/a26d9801/attachment.html>

More information about the petsc-dev mailing list