[petsc-dev] [petsc-users] Error during PETSc build on Edison

Amneet Bhalla mail2amneet at gmail.com
Thu Feb 1 10:32:31 CST 2018

Ok, and how to get rid of runtime error like

[0]PETSC ERROR: PETSc installed without X windows, Microsoft Graphics,
OpenGL ES, or GLUT/OpenGL on this machine

configure with --with-x=0?

On Thu, Feb 1, 2018 at 8:06 AM, Satish Balay <balay at mcs.anl.gov> wrote:

> On Thu, 1 Feb 2018, Amneet Bhalla wrote:
> > P.S: I was also mucking with cray-petsc. However, I could not use it
> > in my application. Cray-petsc is built with parallel hdf5 and some
> > of the libraries I need use serial hdf5. At runtime, the application
> > picks parallel hdf5 and the application crashes :-(. I tried this on
> > my laptop also and got the same result.
> >
> > I think the only way out is to build my own version of PETSc without
> > (parallel) hdf5.
> Sure - its best to install petsc from source - for such special
> requirements.
> Satish

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-dev/attachments/20180201/6704d3ed/attachment-0001.html>

More information about the petsc-dev mailing list