William Gropp gropp at mcs.anl.gov
Fri Aug 17 15:05:07 CDT 2007

On Aug 17, 2007, at 1:10 PM, Scott Atchley wrote:

> Hi all,
> I am trying to run WRF2.1 using MPICH2's ch3:ssm over gigabit  
> Ethernet. When I start the job, I get:
> [cli_0]: aborting job:
> Fatal error in MPI_Comm_size: Invalid communicator, error stack:
> MPI_Comm_size(112): MPI_Comm_size(comm=0x5b, size=0x7fff18349588)  
> failed
> MPI_Comm_size(70).: Invalid communicator

The "comm=0x5b" indicates that the program has been compiled with an  
mpi.h or mpif.h belonging to a different mpi implementation.  The MPI  
objects in MPICH2 have very distinctive values (with bits set in the  
high byte that indicate the type of object).


> for each process. I have compiled MPICH2 and WRF with PGI 6.2.6 and  
> 7.0.7 with the same results. If I run it with -gdb, there are no  
> symbols and I cannot debug. I tried compiling MPICH2 with --enable- 
> g=all and then running it with -gdb, but it hangs and never gives  
> me a gdb command line.
> Does anyone have experience with this?
> Thanks,
> Scott

More information about the mpich-discuss mailing list