[AG-TECH] node configuration problems with multi-machine node

James Miller millerjw at psc.edu
Fri Aug 24 09:04:07 CDT 2007

Nope, no dice. I deleted the node config on display, and removed the 
Video directories from ~/.AccessGrid3/local_services/ Same thing. I 
definately have different devices selected in the node config. Though 
one thing that I think is strange is that I only have 4 capture cards, 
and 8 listed devices when adding a node service...


I seem to remember in the past the devices were only listed as /dev/videoX
and there definately wasn't 2 per device. Either way... if I pick the 
V4L or the V4L2, I get the same result.


Christoph Willing wrote:
> On 24/08/2007, at 5:52 AM, James Miller wrote:
>> I have an XP display machine which runs the venue client and the node 
>> configuration. My capture box for audio and video is an Ubuntu 
>> machine with 4 Hauppauge cards all identical using the bt878 chipset. 
>> I have multiple video producer services set up using streams 
>> /dev/video0 through video3 , but for some reason, when a venue is 
>> launched, all 4 of the capture windows enable the same device 
>> (/dev/video3) The interesting thing is that I can rename the streams 
>> in the node configuration on display, and the stream names make it to 
>> the capture box. For some reason, the ServiceManager just won't open 
>> teh proper device for each stream.
>> Once the streams are up, I can go to the menu of each stream on the 
>> capture box, and select the proper device which brings up the proper 
>> stream, but it still doesn't remember it's setting when switching 
>> venues.
> Jim,
> I just tried a test using AG3.0.2 and the same XP + Ubuntu OS 
> combination. Instead of 4 separate capture cards, I used a single 4 
> input capture card (4x bt878 chips). It seemed to work fine changing 
> between a number of different venues at different servers.
> My guess is that the version of vic has become out of sync with your 
> Video*Services. Could you try the following?
> - on the display machine, remove all the video producer services from 
> your configuration, save it & exit VenueClient.
> - on the capture machine, make sure you have the latest vic and AG 
> toolkit (after updating Synaptic or apt-get).
> - shut down the AGServiceManager. Now erase the Video*Services 
> currently being used; something like:
> rm -rf ~/.AccessGrid3/local_services/Video*
> will do that (assuming you're logged in as the user who normally runs 
> AGServiceManager). New services will be added there when they're needed.
> - restart AGServiceManager.
> - back on the display machine, starte the VenueClient, add the 
> VideoProducerServices again etc.
> chris
> Christoph Willing +61 7 3365 8350
> QCIF Access Grid Manager
> University of Queensland

More information about the ag-tech mailing list