Fw: [AG-TECH] Wierd problems with video using VIC in fedora 3/4

Proshanta Saha proshanta at gmail.com
Sun Sep 4 09:52:52 CDT 2005

Hi Natalia,

Thank you for your response. Yes I was kind of thinking among the same 
lines, and try to search the list. Some of the converstations did discuss 
the issues with vic crashing with FC1 and FC2. I believe starting from FC3 
and FC4 the Video For Linux 2 drivers were built into the kernel and 
resolved several issues with the cx88 series. The latter AG2.3 and
AG2.4releases also resolved some issues with using the V4L
compatability with
V4L2 drivers, so I it works well. However what I am seeing is a little 
different, where the streaming works, but one window would stop sending, and 
muting/unmuting does not help, and restarting the vic causes the window to 
broadcast a green screen. 

Thank you for the tip about reloading the video capture modules, but I have 
tried to use tvtime to verify that the card still works after the green 
screen. So I think the reboot solves more of an AG issue than a driver 
issue. However, as Doug pointed out it could be the manner in which the AG 
toolkit uses a compatablity tool for V4L2 instead of the natives, for very 
good reason (namely users with Quickcams will have difficulties as V4L2 
support is still beta). I believe he will be releasing a possible native 
V4L2 controls for the AG in the coming week, which may help in what I'm 
currently faced with. 


On 9/4/05, Natalia Costas Lago <natalia at cesga.es> wrote:
>   No idea about the real problem, just a suggestion... maybe of rebooting 
> u can remove and reload the kernel module instead?.
>  I noticed the capture card u use has the c88xx chip; time ago (more than 
> a year) I dealt with one of those, the driver was in 0.0.3 version by that 
> time and I could hardly make it work (only with a kernel rebuild and much 
> pain). I remember I posted my enquiries to ag-tech and more people did 
> afterwards, search that thread (there are many concerning cx88 chip) to find 
> some more information. Try a capture card with an 878 chip instead?.
>  Hope this helps,
> Kind regards,
> -----------------------------------
> Natalia Costas Lago
> email: natalia at cesga.es
> Centro de Supercomputacion de Galicia (CESGA)
> Avenida de Vigo, s/n Campus Sur 
> 15706 Santiago de Compostela - SPAIN
> Tel: +34 981 56 98 10 
> Fax: +34 981 59 46 16
> http://www.cesga.es/ 
> ----- Original Message ----- 
> *From:* Proshanta Saha <proshanta at gmail.com> 
> *To:* ag-tech at mcs.anl.gov 
> *Sent:* Saturday, September 03, 2005 7:36 AM
> *Subject:* [AG-TECH] Wierd problems with video using VIC in fedora 3/4
> Hi,
> I've been debugging a non-responsive vic window problem for days, what 
> happens is that for the first 5 mins, I get perfect motion on all 3 cameras. 
> All of a sudden one of them will freeze up. Stoping the session and staring 
> it again causes vic to show a green window, and essentially render that 
> capture card useless. Still works under tvtime, just not with vic. I am 
> almost hitting a brick wall, ie. tried almost everything I could to find out 
> if it was my server(dual core dell 380s), capture card (Hauppauge Winttv 401 
> c88xx version), linux (fedora 4), or the vic software. 
> Step 1: was making sure that the Wintv cards were all good, and had not 
> problem running simultaneously for hrs, a fair amount of burn in tests were 
> done, the tv cards all seem to be able to run at capture mode for hrs with 
> no problem. 
> Step 2: was to see if vic was kind of not so nvidia friendly, the video 
> capture server has a dual head 128mb PCI-E, which I've heard people find not 
> so great to work with under linux. I personally did not find any such 
> problems, running at 1600x1200 just fine, perfect response time and etc. But 
> just for kicks I brought out a dual xeon dell box I had lying around, with 
> more than ample horse power with a pretty simple video card, probably an 
> intel i810 type of a card. Unfortunatley I faced the same problem.
> Step 3: Fedora 4 versus Fedora 3. So I decided to try Fedora 3 with some 
> spare hard disks. Fedora 3 seems surprisingly easy to setup AG with, unlike 
> the mountain I had to climb for Fedora 4. However, it seems to also 
> mysteriously freeze one of the vic screens, after which every session would 
> produce a greed screen on the frozen vic. Only a reboot will fix the green 
> screen problem. But then after 5 mins of starting AG, I'm back to the frozen 
> screen problem.
> Step 4: AG2.3 versus AG2.4, I was very excited when I saw that the screen 
> did not freeze up after five minutes. But alas after about 15 mins or so I 
> get a frozen window, and will show up as a green screen everytime after 
> that. Only a reboot will fix that problem, and would eventually freeze up 
> again.
> Step 5::Move 1 capture card to another machine, as it seems to be able to 
> handle 2 just fine. But it appears that even in this case VIC would cause a 
> frozen screen on one of the windows. And the usual green screen appears. The 
> one with just 1 works perfectly. 
> So I'm kind of running out of ideas, since the capture cards on their own 
> pass the burn in test. Software capture tests all pass. The VIC however 
> mysteriously causes a frozen screen followed by a green screen in next vic 
> startup. 
> Any suggestions would be most welcome. Kind of running out of hair to pull 
> aswell. Thanks in advance.
> Proshanta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/ag-tech/attachments/20050904/71b2ae9b/attachment.htm>

More information about the ag-tech mailing list