[AG-TECH] Invalid Pointer Error

Ashley Wright a2.wright at qut.edu.au
Mon Jul 4 21:35:50 CDT 2005

Hi Doug

If I run rat on its own nothing happens. I get no Window, no output, 
nothing. The program also does not exit.

I tested AccessGrid on a demo machine from HP, it was RHEL4 with only a 
single processor and video card. And it worked fine. However this one 
has been giving me all kinds of grief.


Douglas Kosovic wrote:

> Hi Ashley,
>> My problem is that when I run "VenueClient.py --personalNode" I get 
>> the following error after the audio service is supposed to start.
>> *** glibc detected *** free(): invalid pointer: 0x000000000051305c ***
>> After this the VenueClient shows the participants but there is no VIC 
>> or RAT.
> If you:
>   cd ~/.AccessGrid/local_services/AudioService
>   ./rat
> Does rat then come up without the glibc error message?
> if it doesn't, you could try exiting the VenueClient and kill any AG 
> processes, then:
>  rm -rf ~/.AccessGrid/local_services/*
> the next time you restart the venueClient, the contents of that 
> directory will be populated again.
>> Is anybody able to help me with this problem?
>> If you need more information let me know.
> I've never tested the AGTk 2.3 Fedora Core 3 x86-64 RPMs on RHEL4 
> x86-64, I just assumed that they would work.
> Cheers,
> Doug

Ashley Wright
3864 9264
a2.wright at qut.edu.au
HPC and Research Support Group
Queensland University of Technology (QUT)

More information about the ag-tech mailing list