[AG-TECH] Invisible Rat (AG2.3, RedHat 9 Linux)

Douglas Kosovic douglask at itee.uq.edu.au
Fri Dec 3 08:15:44 CST 2004

Hi Dave,

> I'm seeing similar things with FC2, would the Audioservice.zip you linked 
> work in my case too?

On FC2 the rat GUI not coming up problem is most typically due to a
firewall/networking related issue. In some cases it was because they
were running the OSS module for their soundcard driver (which isn't
common, as Alsa is the default soundcard driver for FC2).

Since AccessGrid-2.3-5.i386.rpm, I've been compiling rat with gcc-2.96
from the compat-gcc-7.3-2.96.126.i386.rpm package, which fixed the
problem of the rat GUI not coming up if the OSS driver (and I don't mean
the OSS compatibility layer of Alsa) was used.

You could try that AudioService.zip file that was compiled on FC1. I've
run a rat on FC2 that was compiled on FC1 and it worked.

> On Fri, 3 Dec 2004, Douglas Kosovic wrote:
> > Hi Andrew,
> > 
> > With the FC1 AccessGrid-2.3-5.i386.rpm and AccessGrid-2.3-6.i386.rpm, I 
> > forgot to increase the version number in
> > AudioService.svc (located in AudioService.zip), if it's not increased, then 
> > the contents of the following
> > folder don't get replaced with a newer version of rat:
> >    ~/.AccessGrid/local_services/AudioService
> > 
> > [I did remeber to increase the version number with the FC2 AudioService.zip]
> > 
> > So, you could do the following (but make sure AGServiceManager.py is not
> > running) :
> >    rm -rf ~/.AccessGrid/local_services/AudioService
> > 
> > Restart the ServiceManager and a new AudioService will get unpacked the 
> > first time AudioService is used.
> > 
> > The rat that comes with AccessGrid-2.3-5 and later was rebuilt with 
> > gcc-2.9.6 (instead of gcc 3.x), which seemed to fix the problem of the rat 
> > GUI not coming up in some situations. Also rat now has alsa lib statically 
> > linked, so I could remove the alsa-lib RPM dependency.
> > 
> > Recently Steve Smith cleaned up and fixed some of the rat source code (see 
> > "Big Linux fixup patch" thread in ag-tech mailing list). I've rebuilt rat 
> > with Steve's patches, if you want to try it, download:
> >   http://www.itee.uq.edu.au/~agn/ag_fedora/FC1/stable/patches/AudioService.zip
> > to replace:
> >   /etc/AccessGrid/NodeServices/AudioService.zip
> > 
> > It should automatically get unpacked as I've increased the version number in 
> > AudioService.svc.
> > 
> > > I put AG 2.3 (from the UQ FC1 rpms) on a desktop running RedHat 9. When
> > > Rat runs, the UI never appears, though the ui and media tasks seem to be
> > > running OK. I tried both the AG2.3 and AG2.2 Rat (on other machines I've
> > > had problems with the Alsa patched Rat; one one alsaconfig says "no
> > > cards" but OSS runs fine...), and along the way I found that if iptables
> > > stops Rat talking to 224.something it hangs until it can. But this is a
> > > different problem - the Rat from VRVS works OK. In fact, I've packaged
> > > that one into AudioService.zip and it works, but I'd like to solve the
> > > problem as the interface is slightly different - handling of spaces in
> > > venue names, codec support etc.


More information about the ag-tech mailing list