[AG-TECH] New Shared Image tool

sheetal spatil at iupui.edu
Mon Apr 12 16:16:55 CDT 2004

Hi Dave,

The tool works great!!!

When I installed it for the 1st time, I got some errors. I did a re-install
and it worked fine.

AGSharedObject: initialize with url = https://vv2.mcs.anl.gov:9000/213
AGSharedObject: Getting application proxy
AGSharedObject: join application
AGSharedObject: get data channel
AGSharedObject: connected and event channel started
Registering event NewImage :
Registering event NewMarks :
looking for data: ImageFile
looking for data: MarkupData
Loading image:  Water lilies.jpg
Traceback (most recent call last):
  File "AGBasicImage.py", line 427, in ?
    app = MyApp(0)
  File "C:\Python22\Lib\site-packages\wxPython\wx.py", line 1957, in
  File "AGBasicImage.py", line 422, in OnInit
    frame = ImageFrame(None,-1)
  File "AGBasicImage.py", line 316, in __init__
    localImageFile = self.AG.DownloadFile(animage)
  File "AGBasicImage.py", line 137, in DownloadFile
  File "C:\Python22\Lib\site-packages\AccessGrid\DataStoreClient.py", line
in LoadData
    descList = self.datastoreProxy.GetDataDescriptions()
 line 3660, in __call__
    return self.__r_call(*args, **kw)
 line 3680, in __r_call
    self.__hd, self.__ma)
 line 3580, in __call
    config = self.config)
ne 188, in call
  File "C:\Python22\lib\httplib.py", line 695, in endheaders
  File "C:\Python22\lib\httplib.py", line 581, in _send_output
  File "C:\Python22\lib\httplib.py", line 548, in send
, line 1084, in connect
, line 663, in connect
pyGlobus.io.GSITCPSocketException: a system call failed (Unknown error)


-----Original Message-----
From: owner-ag-tech at mcs.anl.gov [mailto:owner-ag-tech at mcs.anl.gov] On Behalf
Of George Estes
Sent: Monday, April 12, 2004 2:38 PM
To: ag-tech at mcs.anl.gov
Subject: Re: [AG-TECH] New Shared Image tool

  Don't know why but just coping the file did not work for me.  I had to go
through the install process and it worked.   Anyway, pretty cool but it
needs an undo command.


At 10:18 AM 4/12/2004 -0500, you wrote:
>X-Envelope-From: semeraro at ncsa.uiuc.edu 
>X-Envelope-To: <ag-tech at mcs.anl.gov> 
>X-Sender: semeraro at mail.ncsa.uiuc.edu (Unverified) 
>X-Mailer: QUALCOMM Windows Eudora Version 5.1 
>Date: Mon, 12 Apr 2004 10:18:40 -0500 
>To: ag-tech at mcs.anl.gov 
>From: Dave Semeraro <semeraro at ncsa.uiuc.edu> 
>Subject: [AG-TECH] New Shared Image tool 
>X-Spam-Status: No, hits=0.0 required=5.0 
>        tests=none 
>        version=2.55 
>X-Spam-Checker-Version: SpamAssassin 2.55 ( 
>Sender: owner-ag-tech at mcs.anl.gov 
>X-Deliver-To: gestes 
>X-MD5SUM: a6100c44149c7bd740c8dea5b3b15891 
>Hello folks,
>I finally finished adding markup capability to the shared image viewer.
That means that once
>an image is loaded you can use the mouse and left mouse button to draw on
the image
>with a pen. Click the left mouse button and hold it down while you draw on
the image. When
>you release the left button the coordinates of what you drew are uploaded
to the venue and
>all the other image viewers are updated. You will just see the image change
to include the
>marks made by the user. The marks do not show up incrementally. Hey it was
the easiest
>I also added the capability to change pen color. This is handy when others
are marking on

More information about the ag-tech mailing list