[AG-TECH] enter venue/venue server on AG2.0 final

Lewis Grantham reavlew at ucl.ac.uk
Sun Jul 6 17:35:22 CDT 2003

Hi all,

have followed similar threads here to little avail.  This is not an issue with
cfg or dat files it seems, and after some digging have decided to post this to
see if theres any undocumented way foward.

I am runnning w2k/sp4 machines with all the recommended bits from:

details on request of course - but vanilla flavour Ag2.0final)

Am also running on UK E-Science certificates and signing policy, if thats in any
way important. (i.e. Not Ti Leggett supplied ones)

we have two intended machines in the main - a dedicated display server, and an
encoder (audio and video production services on one base unit).  A third control
server can perform any roles (node management/sevice etc) as required.

Everything appears to work fine, we can manage the node, set up all services
required, and run all service related py scripts in -d mode with no obvious

However, we cannot under any circumstances join our own venue server
effectively.  When we run any VenueClient script ,we get the same error as
others here have:

 (venueState, self.privateId, streamDescList ) = Client.Handle( URL 
).get_proxy().Enter( self.profile )

followed by:

faultType: <Fault SOAP-ENV:Client: No method Enter found>

I have gone carefully through the py scripts adding 'print' markers to track
this.  The method Venue.Enter is never run or accessed, which is the one I am
presuming should be kicking in at this point.  Both VenueClient.enterVenue
methods are accessed (toolkit and site_packages) up to and including the above
code snippet, which fails.

A print statement one line above this cope snippet in the VenueClient script to
print Client.Handle(URL), outputs a text string of the https:// for our venue
server.  After that, nothing.  Another print command for Client.Handle( URL 
).get_proxy() prints out some kind of stack address or similar bunch-o-numbers,
whch I dont have to hand right now, but can get if important.

In line with some other comments made on this list, I have installed a single
system, with Ag2.0rc1, and tried to access the Ag2.0 final venue server with it,
and this does work, and correctly reports a default set up.  However, having
looked at the amount of changes since RC1, especially in these venue 'states'
and scripts, I am very doubtful theres any possible mixed use advisable.

So, is this just a UK thing? Something amiss with UK E-Science certs mayhap?
Some host or service certs we need to fix up? or a w2k/python mystery? 

Bye for now

Lewis Grantham LLB MSc                                   
Project Leader, Multimedia Unit                          
Media Resources, UCL (University College London)         
Windeyer Building, Cleveland Street, London W1P 6DB      
Tel: (+44) 020 7679 9258    Fax: (+44) 020 7580 0995     
URL: http://www.ucl.ac.uk/mediares/mmedia

More information about the ag-tech mailing list