[AG-TECH] bttv drivers on Redhat 7.3

Don Morton morton at cs.umt.edu
Thu Aug 15 18:15:18 CDT 2002

Ya know, this is probably a dorky fix, and might not be what
you're looking for, but it surprisingly worked for me....

I had the AG 1.0 which, I believe was based on RH 6.2, and
before I upgraded to Redhat 7.3, I saved the contents of

Once I installed Redhat 7.3, I untarred the /usr/local/ag
I'd saved from Redhat 6.2 (AG 1.0) and everything worked
fine.  No need to recompile bttv drivers, etc...  


JB Gallagher wrote:
> Hello All,
> Does anyone out there have any pointers for getting the bttv drivers to
> work (or even build) under RedHat 7.3 (kernel 2.4.18-7)? I've followed
> all the directions on different bttv related web sites (main point being
> I patched my 2.4.x kernel with a patch generated by a script that came
> with the bttv source), but in the end I can't get bttv-driver.c to even
> compile. I'm using bttv version 0.7.65, and I get a compiler error with
> a function in the first piece of c code (bttv-driver.c) complaining that
> a function has too few arguments passed to it. I don't have the exact
> error handy because the machine the attempted build was done on is
> currently down, but the error is ana ctual syntax error, I'm sort of
> wondering if the stock gcc with redhat 7.3 has problems. At any rate I
> was just wondering if anyone had tried this yet and what sort of
> problems they encountered.
> thanks,
> Brad Gallagher
> ASCI Flash Center
> jbgallag at flash.uchicago.edu
> 773-834-3236

   Don Morton                   http://MRoCCS.cs.umt.edu/~morton/
   Department of Computer Science       The University of Montana
   Missoula, MT 59812 | Voice (406) 243-4975 | Fax (406) 243-5139

More information about the ag-tech mailing list