[petsc-users] TSPseudo Solution Algorithm

Smith, Barry F. bsmith at mcs.anl.gov
Fri Mar 30 13:18:57 CDT 2018

   This happens because there are zeros on the diagonal that cause the zero pivot, presumably the zero diagonal entries come from the algebraic equation portion of the DAE.

   You can try the following option -sub_pc_factor_nonzeros_along_diagonal


> On Mar 30, 2018, at 3:33 AM, Mohammad Hassan Baghaei <mhbaghaei at mail.sjtu.edu.cn> wrote:
> Hello
> I am trying to solve system of equations using time stepping. I use TSSetIFunction() to define the DAEs. I tried to add the xdot[] term to all of variables. As a solution algorithm , I solved with newton line search with ASM as a preconditioner. In the case, I want to add the xdot[] term to only one term, energy equation, I got   PCSETUP_FAILED due to FACTOR_NUMERIC_ZEROPIVOT and failed to solve. Do you know how I can deal with this? So Sorry for may be confusing you with my explanation! If you need more information of my case, let me know. Thanks for your time answering. 
> Thanks
> Amir

More information about the petsc-users mailing list