[petsc-users] Tao's user-defined Monitor crashes

Dener, Alp adener at anl.gov
Fri Jul 20 20:58:49 CDT 2018

Hi Shu,

I can confirm that I’m getting the same error on my end as well. I checked the eptorsion2f test and I don’t see anything immediately wrong with it. I think something may be bugged about the Fortran interface for TaoSetMonitor, or alternatively the internal fortran function pointer mapping for monitors, monitor contexts and monitor destroy functions. I will take a closer look at this over the weekend and we will get a fix for this tested and merged to master as soon as possible.



Alp Dener
Argonne National Laboratory

On July 20, 2018 at 8:19:12 PM, Shu Wang (shuwang12 at unm.edu<mailto:shuwang12 at unm.edu>) wrote:

Hi all,

I ran into a error with user-defined tao's monitor with TaoSetMonitor in Fortran.

When I ran the example eptorsion2f in $PETSC_DIR/src/tao/unconstrained/examples/tutorials/ with '-testmonitor', there split the following error,

[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range
[0]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[0]PETSC ERROR: or see http://www.mcs.anl.gov/petsc/documentation/faq.html#valgrind
[0]PETSC ERROR: or try http://valgrind.org on GNU/linux and Apple Mac OS X to find memory corruption errors
[0]PETSC ERROR: likely location of problem given in stack below
[0]PETSC ERROR: ---------------------  Stack Frames ------------------------------------
[0]PETSC ERROR: Note: The EXACT line numbers in the stack are not available,
[0]PETSC ERROR:       INSTEAD the line number of the start of the function
[0]PETSC ERROR:       is given.
[0]PETSC ERROR: [0] TaoCancelMonitors line 1444 /home/ws/Softwares/petsc-3.9.3/src/tao/interface/taosolver.c
[0]PETSC ERROR: [0] TaoDestroy line 276 /home/ws/Softwares/petsc-3.9.3/src/tao/interface/taosolver.c
[0]PETSC ERROR: --------------------- Error Message -------------------------------------------------------------

My configuration for petsc-3.9.3 is as follows:

--with-metis-dir=/usr/local/ --with-parmetis-dir=/usr/local/ --download-hdf5 -with-debugging=1 --with-mpi-dir=/usr/local/openmpi --download-fblaslapack --with-fortran-datatypes.

and the compiler is gcc-4.7.4 with openmpi/2.0.1.
Is there any bug associate with tao's destroy routine with user-defined monitor is invoked?

Any comments are welcomed.

Yours sincerely,

Shu Wang
Electrical and Computer Engineering Department of University of New Mexico
Albuquerque, NM
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-users/attachments/20180721/05e24d3a/attachment.html>

More information about the petsc-users mailing list