[petsc-users] Could not find make when building PETSc in Windows 7

Chetan Jhurani chetan.jhurani at gmail.com
Thu Oct 24 11:29:00 CDT 2013

I vaguely recall seeing the "could not locate make" error
when a non-cygwin python is picked up first in path.
So ensure that "which python" points to cygwin python.

Another issue is that the --with-make argument, if it is
needed, should be /cygdrive/C/cygwin64/bin (or with some
other drive letter in between where cygwin is installed).


> -----Original Message-----
> From: petsc-users-bounces at mcs.anl.gov [mailto:petsc-users-bounces at mcs.anl.gov] On Behalf Of Qin Lu
> Sent: Thursday, October 24, 2013 8:43 AM
> To: Jed Brown; petsc-users at mcs.anl.gov
> Subject: Re: [petsc-users] Could not find make when building PETSc in Windows 7
> Jed,
> As I mentioned, I did add C:\cygwin64\bin (where make.exe is) to Path, and also tried to run
> ./configure --with-cc='win32fe icl' --with-fc='win32fe ifort' --with-cxx='win32fe icl' --with-
> make=/cygdrive/cygwin64/bin. It did not work, I just tried what you suggested: adding --download-make
> in confugure, it gave the same error.
> Thanks,
> Qin
> On Thursday, October 24, 2013 10:36 AM, Jed Brown <jedbrown at mcs.anl.gov> wrote:
> Qin Lu <lu_qin_2000 at yahoo.com> writes:
> > Hello,
> >
> > I am trying to build PETSc in Windows 7 with following steps:
> >
> > 1. Installed cygwin 64-bit with python, make and other default packages under C:\cygwin64
> > 2. Added C:\cygwin64\bin to Windows environmental variable Path.
> > 3. Downloaded and unzipped PETSc 3.4.2.
> > 4. Run mintty.exe to open a cygwin terminal.
> > 5. In the cygwin terminal, under PETSc directory, run:  ./configure --with-cc='win32fe icl' --with-
> fc='win32fe ifort' --with-cxx='win32fe icl'
> >
> > However, it gave an error "Could not locate the make utility on your system, make sure it is in your
> path or use --with-make=/fullpathnameofmake and run ./configure again".  I suppose it should use
> C:\cygwin64\bin\make.exe, which is already in path, but I still added  --with-
> make=/cvgdrive/cygwin64/bin in configure's option and run configure again, yet it gave the same error.
> You need to pass the full path to the make executable (or add it to your
> path), or you can use --download-make.
> > What should I do to let configure know the path of make?
> >
> > Many thanks for your help,
> >
> > Regard,
> > Qin

More information about the petsc-users mailing list