[petsc-users] snes/examples/tutorials/ex3 x-window plot issue

Zou (Non-US), Ling ling.zou at inl.gov
Thu Apr 18 11:21:53 CDT 2013

Hi, All

I tried snes/examples/tutorials/ex3 on my Mac OS 10.7.5, with X11 (XQuartz
2.6.5 (xorg-server 1.10.6)) installed. Everything seems fine, as I got
output from the terminal as:

atol=1e-50, rtol=1e-08, stol=1e-08, maxit=50, maxf=10000
iter = 0,SNES Function norm 5.41468
iter = 1,SNES Function norm 0.295258
iter = 2,SNES Function norm 0.000450229
iter = 3,SNES Function norm 1.38967e-09
Number of SNES iterations = 3

Norm of error 1.49751e-10 Iterations 3

I suppose it is right. The only thing which bothers me a little bit is the
x-window plot. When I ran the code, I could see a x-window plot flashing on
my screen and it's gone forever. I don't know if it is supposed to be like
this, or I should see an x-window plot staying on my screen.

Anyway, this is not a big issue and I guess it is most likely not a PETSc
problem. My X11 should be fine too, as when I do gnuplot, the x-window
shows stuffs correctly. However, I'd appreciate if anyone could give a hint
how to resolve it.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-users/attachments/20130418/61dbb14f/attachment-0001.html>

More information about the petsc-users mailing list