[petsc-users] configure failed on MPI and Intel Compiler environment

NovA av.nova at gmail.com
Wed Apr 7 17:57:43 CDT 2010


I'm not a PETSc developer but have some thoughts about the issue...

I've got similar errors trying to build with MKL-10 on Windows. Intel
MKL v10+ has very different libraries layout as against previous
versions (see users manual). It seems that PETSc configure script
can't deal with this new layout yet. So you need to specify exact
blas-lapack library file names manually via "--with-blas-lapack-lib"
option. The value
"${MKL_DIR}/libmkl_sequential.a", "${MKL_DIR}/libmkl_core.a"] worked
for me.


2010/4/7 Takuya Sekikawa <sekikawa at msi.co.jp>:
> Dear Petsc developpers,
> I tried to configure PETSc (ver 3.0)
> on Linux (64bit), MPI-enabled, Intel Compiler (icc/icpc) environment,
> but it failed.
> ./config/configure.py --with-mpi=1 --with-mpi-dir=/opt/home/sekikawa/bin-personal/mpich2 \
> --with-x=0 --with-fc=0 --with-debugging=0 --with-blas-lapack-dir=${MKL_DIR}
> =================================================================================
>             Configuring PETSc to compile on your system
> =================================================================================
> =================================================================================
>                WARNING! Compiling PETSc with no debugging, this should
>                      only be done for timing and production runs. All development should
>                      be done when configured using --with-debugging=1
> =================================================================================
> TESTING: checkLib from config.packages.BlasLapack(config/BuildSystem/config/packages/BlasL*********************************************************************************
>         UNABLE to CONFIGURE with GIVEN OPTIONS    (see configure.log for details):
> ---------------------------------------------------------------------------------------
> You set a value for --with-blas-lapack-dir=<dir>, but /opt/intel/mkl/10.0.010/lib/em64t cannot be used
> *********************************************************************************
> MKL_DIR is set to intel mkl library.
> without MPI (--with-mpi=0), this configure succeeded with no problem.
> and MPICH2 is successfully compiled and running with Intel compiler.
> I would very much like for any suggestion.
> Thanks in advance.
> Takuya
> ---------------------------------------------------------------
>   Takuya Sekikawa
>         Mathematical Systems, Inc
>                    sekikawa at msi.co.jp
> ---------------------------------------------------------------

More information about the petsc-users mailing list