[petsc-dev] Merge request error

Ali Reza Khaz'ali arkhazali at iut.ac.ir
Sat Dec 5 12:43:28 CST 2020

Dear Satish,

I tried to use "git push" to push my branch to the origin (i.e. mainstream
PETSc repo). However, instead of receiving the URL for creating a merge
request, I got the following error:
fatal: unable to access 'https://gitlab.com/petsc/petsc.git/': The requested
URL returned error: 403

I supposed that the error was because of my unfamiliarity with GitLab.
Therefore I tried to use GitLab web interface at:

which is giving me a 404 error.

Many thanks,

-----Original Message-----
From: Satish Balay <balay at mcs.anl.gov> 
Sent: Saturday, December 05, 2020 8:32 PM
To: Ali Reza Khaz'ali <arkhazali at iut.ac.ir>
Cc: 'petsc-dev' <petsc-dev at mcs.anl.gov>
Subject: Re: [petsc-dev] Merge request error

The relevant instructions on creating a merge request from a fork are at

Would it be possible to provide details on how you tried to create a merge
request - and what exactly failed?


On Sat, 5 Dec 2020, Ali Reza Khaz'ali wrote:

> Hi,
> I want to fix an issue in petscsys.h that prevents the code from being 
> compiled by icl on Windows. However, I cannot create a merge request, 
> and GitLab web interface link shows a 404 error. I would be grateful 
> if you could provide guidance on the matter.
> Best wishes,
> Dr. Ali Reza Khaz'ali
> Assistant Professor of Petroleum Engineering & Director of Student 
> Affairs,
> Department of Chemical Engineering
> Isfahan University of Technology
> Isfahan, Iran

More information about the petsc-dev mailing list