[petsc-dev] WSL upgrade

Sean Farley sean at farley.io
Thu Apr 13 02:37:30 CDT 2017

Satish Balay <balay at mcs.anl.gov> writes:

> On Wed, 12 Apr 2017, Jed Brown wrote:
>> >> This is the error message that old blog post refers to
>> >> 
>> >>   https://blogs.msdn.microsoft.com/commandline/2016/10/19/interop-between-windows-and-bash/
>> >> 
>> >> and the new post runs exactly the same command without error.  Can you
>> >> run "notepad.exe sizeof.c"?
>> >
>> > I get the same error as the blog..
>> The new one runs that exact command successfully.  See
> I'm on the new one. (version 1703, buid: 15063.138)
>>   Windows <-> Linux Interop
>> https://blogs.msdn.microsoft.com/commandline/2017/04/11/windows-10-creators-update-whats-new-in-bashwsl-windows-console/
> Notice the path (/mnt/c/temp) - its Windows FS - not WSL FS. That
> works fine [as I mentioned earlier with my example usage]

For shits and giggles, I set up a windows 10 vagrant box because I
didn't believe Microsoft would have solved path mapping between Windows
and WSL / ubuntu files.

I get the same errors Satish posted (Satish, as always, you right).

vagrant at win10:~$ cd
vagrant at win10:~$ echo foo >> foo.txt
vagrant at win10:~$ notepad.exe foo.txt # error; can't find file
vagrant at win10:~$ cd /mnt/c
vagrant at win10:/mnt/c$ mkdir foo; cd foo
vagrant at win10:/mnt/c/foo$ echo foo >> foo.txt
vagrant at win10:/mnt/c/foo$ notepad.exe foo.txt # works
vagrant at win10:/mnt/c/foo$ notepad.exe $PWD/foo.txt # error

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 800 bytes
Desc: not available
URL: <http://lists.mcs.anl.gov/pipermail/petsc-dev/attachments/20170413/0d9b96c2/attachment.sig>

More information about the petsc-dev mailing list