[petsc-dev] Naming convection: DMDAGetCoordinateDA()

Barry Smith bsmith at mcs.anl.gov
Sun Nov 7 18:50:01 CST 2010

On Nov 7, 2010, at 3:22 PM, Jed Brown wrote:

> On Sun, Nov 7, 2010 at 22:10, Dave May <dave.mayhem23 at gmail.com> wrote:
> Barry,
>  What's the convention for names of getter functions in PETSc?
> Just wondering if
>  DMDAGetCoordinateDA()
> should be changed for consistency to
>  DMDAGetCoordinateDM() or DMDAGetCoordinateDMDA()
> Wait, isn't this actually base DM functionality?  DMGetCoordinateDM?

   We could move it over to base functionality then the naming issue disappears. If it is not moved over to base then it should be DMDAGetCoordinateDMDA(), I missed it in my mass name change.


> Jed

More information about the petsc-dev mailing list