[petsc-dev] Naming convection: DMDAGetCoordinateDA()

Jed Brown jed at 59A2.org
Sun Nov 7 15:22:49 CST 2010

On Sun, Nov 7, 2010 at 22:10, Dave May <dave.mayhem23 at gmail.com> wrote:

> Barry,
>  What's the convention for names of getter functions in PETSc?
> Just wondering if
>  DMDAGetCoordinateDA()
> should be changed for consistency to
>  DMDAGetCoordinateDM() or DMDAGetCoordinateDMDA()

Wait, isn't this actually base DM functionality?  DMGetCoordinateDM?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-dev/attachments/20101107/91911978/attachment.html>

More information about the petsc-dev mailing list