[mpich-discuss] Program uses 100% with MPICH2 (<10% with MPICH1)

asco developer ascodev at gmail.com
Tue Jul 24 15:43:50 CDT 2012


I have a compile C program where communication between process is
implemented using MPI (more precisely MPICH1). In 2005 this seemed to
be a good option and I have kept using this version until today.

Recently a user of the program (free software hosted on
sourceforge.net) tried MPICH2 and reported huge CPU usage. I tried
myself with both version mpich2-1.4.1p1 and mpich2-1.5b2 and I got the
same results. The binary (compiled C code on Linux) uses 100% CPU and
run slowly. Interesting for me it is the fact that if I renice the
process to the lowest possible priority, the performance with MPICH2
gets similar to the MPICH1 counterpart. This puzzles me as with this
result I do know not where to start looking.

Before start posting lots information, possible not really the one you
would need, I ask for your suggestions on what type of information do
you need from my side. The master node sends about 100 MPI_DOUBLE to 1
slave (100/n for n slaves) and little information is printed on
stdout. Each one of the slave processes then executes another binary
external program via the C "system" function call. I have looked
around and I have found this entry in the discussion list,
but I'm not sure if it applies to me, and Hydra is not using CPU, my
program is.

João Ramos

More information about the mpich-discuss mailing list