[mpich-discuss] problem with installing mpich2-1.4.1

Xiao-lin "Nick" Wu nick.wu at ansci.wisc.edu
Thu Aug 25 12:29:00 CDT 2011


Thanks! Please find "config.log" in the attachment.



From: mpich-discuss-bounces at mcs.anl.gov [mpich-discuss-bounces at mcs.anl.gov] On Behalf Of Dave Goodell [goodell at mcs.anl.gov]
Sent: Thursday, August 25, 2011 11:13 AM
To: mpich-discuss at mcs.anl.gov
Subject: Re: [mpich-discuss] problem with installing mpich2-1.4.1

On Aug 25, 2011, at 9:46 AM CDT, Xiao-lin Nick Wu wrote:

> I tried to install mpich2-1.4.1 on our workstations. It worked well except on one machine. On that machine, it passed the configuration but gave error message when I tried to build it. Attached are two files: c.txt and m.txt. Please let me know how I can fix it.

The problem looks like string.h on your system #defines strncmp to some inline macro but MPICH2 attempts to provide a "missing" prototype for strncmp.  The prototype probably isn't actually missing, the PAC_FUNC_NEEDS_DECL configure macro is probably broken instead in this sort of environment.

Can you send us the "config.log" file from your build as well?  That will help us confirm and fix the problem.

I feel like we've encountered this and dealt with it before in some way, but I can't remember anything specific and I didn't find anything by googling and searching my email archives.


mpich-discuss mailing list
mpich-discuss at mcs.anl.gov
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 337101 bytes
Desc: config.log
URL: <http://lists.mcs.anl.gov/pipermail/mpich-discuss/attachments/20110825/db234fec/attachment-0001.obj>

More information about the mpich-discuss mailing list