[mpich-discuss] Running MPIEXEC on Windows 7

Phelan Jr., Frederick R. Dr. frederick.phelan at nist.gov
Tue Apr 12 14:02:36 CDT 2011


I had tons of problems getting MPICH to fly. The procedure below finally worked for me (culled from various sources):

	1. Uninstall previous version of MPICH2
	2. Open an admin command prompt by right-clicking on the command prompt icon and selecting "run as administrator"
	3. Run "msiexec /i mpich2-1.3.2p1-win-ia32.msi" from the admin command prompt to install MPICH2
	4. During installation select that MPICH2 be installed for "Everyone" for all users.
	5. Run wmpiconfig and store username/password.
	6. Add "C:\Program Files\MPICH2\bin" to system Path and reboot
	7. Check smpd using 'smpd -status'. it should return 'smpd running on $hostname$'
	8. To test execution environment, go to the directory $MPICHROOT\examples and run cpi.exe using: 'mpiexec -n 4 cpi'

Pasted from <http://lists.mcs.anl.gov/pipermail/mpich-discuss/2010-February/006529.html> 
Pasted from <http://lists.mcs.anl.gov/pipermail/mpich-discuss/2011-January/008826.html>

One last thing ... even on a 64-bit system, you may need the 32-bit version depending on what binary you are running. I have a 32-bit binary, the instructions above reflect installation of the 32-bit version of MPICH2 for that reason.


-----Original Message-----
From: mpich-discuss-bounces at mcs.anl.gov [mailto:mpich-discuss-bounces at mcs.anl.gov] On Behalf Of Jayesh Krishna
Sent: Tuesday, April 12, 2011 10:05 AM
To: mpich-discuss at mcs.anl.gov
Subject: Re: [mpich-discuss] Running MPIEXEC on Windows 7

 This seems to be a problem with the MPICH2 installation (Although you are not getting any error messages it looks like the process manager was not installed correctly).
 Uninstall your existing version of MPICH2. Please follow the instructions in the MPICH2 installer's guide (http://www.mcs.anl.gov/research/projects/mpich2/documentation/index.php?s=docs - Section 9.4) to install MPICH2 (Don't follow instructions in 9.1).

 Let us know if it works for you.


----- Original Message -----
From: "Alan L Flint" <aflint at usgs.gov>
To: mpich-discuss at mcs.anl.gov
Sent: Monday, April 11, 2011 4:38:34 PM
Subject: [mpich-discuss] Running MPIEXEC on Windows 7

I have been successfully running all my parallel codes on Windows NT. I've had one computer converted to Windows 7 and cannot get mpiexec to run even the simple cpi example. My command in an Adminstrator MS-DOS prompt is: 

mpiexec -n 4 cpi 

I get back the following error: 

Error while connecting to host, No connection could be made because the target machine actively refused it. (10061) 
Connect on sock (host=igswcawwws1889.gs.doi.net, port=8676) failed, exhaused all end points 
Unable to connect to 'igswcawwws1889.gs.doi.net:8676', 
sock error: Error = -1 

I've also run it using wmpiexec and get the same result. I've allow mpiexec and cpi to run under the Windows firewall so I'm not sure what to look for in Windows 7. 


mpich-discuss mailing list
mpich-discuss at mcs.anl.gov
mpich-discuss mailing list
mpich-discuss at mcs.anl.gov

More information about the mpich-discuss mailing list