[mpich-discuss] Errors while install MPICH on a 64bit cluster

chan at mcs.anl.gov chan at mcs.anl.gov
Tue Oct 13 23:55:59 CDT 2009

Lei Yang,

/export/users/nbtester/...../for_main.c looks like a source file
for ifort compiler.  "ifort -lc" produced a similar message.  
Anyway, have you tried using mpif90 to compile anything ?  Try
"make installcheck" in the mpich2 build directory (where you
executed "make" and "make install") but be sure to launch "mpd"
first.  You can send us the "make installcheck" output.


----- "Lei Yang" <lei.miren.yang at gmail.com> wrote:

> I apologize for sending wrong files last time, this time is certainly
> MPICH2-1.2 I set environmental variables like this:
> export FC=/opt/intel/fce/10.0.023/bin/ifort
> export F90=/opt/intel/fce/10.0.023/bin/ifort
> export CC=gcc
> Didn't see any errors in the files, but when I run "mpif90 -echo", it
> gave this error message:

... snip ...
> + /opt/intel/fce/10.0.023/bin/ifort -I/home/yanglei/mpich2/include
> -I/home/yanglei/mpich2/include -L/home/yanglei/mpich2/lib
> -L/home/yanglei/mpich2/lib -lmpichf90 -lmpichf90 -lmpich -lopa
> -lpthread -lrt
> /opt/intel/fce/10.0.023/lib/for_main.o: In function `main':
> /export/users/nbtester/efi2linuxx86_nightly/branch-10_0/20070427_000000/libdev/frtl/src/libfor/for_main.c:(.text+0x26):
> undefined reference to `MAIN__'
> + rc=1
> + '[' -n '' ']'
> + exit 1
> and we don't even have /export/users/nbtester...directory. and
> obviously the mpif90 doesn't work...

More information about the mpich-discuss mailing list