[mpich-discuss] -mpe=mpitrace not producing any output, and Valgrind outputs on r3717

Anthony Chan chan at mcs.anl.gov
Mon Jan 5 13:00:09 CST 2009

I am mainly answering the MPE related issue here.

----- "François PELLEGRINI" <francois.pellegrini at labri.fr> wrote:

> Hello and happy new year to all,
> Several topics are addressed in this e-mail.
> First, I have trouble using the "mpitrace" feature of MPE.
> I compile all of my source code with "mpicc -mpe=mpitrace",
> and link the objects with "-ltmpe", but absolutely no output
> is produced when I run the compiled program. This both happens
> with the official 1.0.8 and r3717 packages. What did I do
> wrong ?

just tried -mpe=mpitrace with cpi.c in 
I see trace output appears on my terminal.
What program are you trying this ?
If the program is small, can you send me the
code so I can check/confirm if MPE has any bug ?

In terms of Valgrind, did you configure mpich2 with --enable-g=meminit
which reduces some valgrind warnings...?  See "configure --help"
for more info.


More information about the mpich-discuss mailing list