[mpich-discuss] mpich2 / openmpi conflicts on osx 10.5?

Jeff Squyres jsquyres at cisco.com
Thu Dec 18 07:42:03 CST 2008

FWIW, you shouldn't even need to "hide" the default MPI that ships  
with Leopard by putting it in another directory.  If you just set your  
PATH to point to /usr/local/bin before it points to /usr/bin, you  
should be fine (I do this all the time on my MacBook Pro laptop).

On Dec 17, 2008, at 9:22 PM, Thomas Blom wrote:

> Thanks.  Perhaps that would have worked.  What I ended up doing was  
> "hiding" the headers, libs, and exes for the openmpi that came  
> installed on the mac.  Then I did the configure, make, and make  
> install again, and it worked.
> -thomas
> On Wed, Dec 17, 2008 at 11:12 PM, Rajeev Thakur <thakur at mcs.anl.gov>  
> wrote:
> Just try logging out and log back in again.
> Rajeev
> From: mpich-discuss-bounces at mcs.anl.gov [mailto:mpich-discuss-bounces at mcs.anl.gov 
> ] On Behalf Of Thomas Blom
> Sent: Wednesday, December 17, 2008 10:06 PM
> To: mpich-discuss at mcs.anl.gov
> Subject: [mpich-discuss] mpich2 / openmpi conflicts on osx 10.5?
> Hello,
> I've successfully used mpich2 on windows and on a couple of other  
> osx machines, but having just built mpich2 from source on a new mac  
> pro I encounter difficulty when trying to run some mpi programs.
> OSX 10.5 ships with OpenMPI apparently, such that there are mpi*  
> programs in /usr/bin
> I accepted the default when configuring/building/installing mpich2,  
> such that it gets installed to /usr/local/bin
> Once I realized that the wrong mpiexec was getting called, I chose  
> to "hide" the /usr/bin versions (not knowing otherwise how to  
> disable or uninstall the openmpi) by just creating a folder  
> _mpi_hidden in /usr/bin and placing all those mpi* programs in there.
> Now when I type "which mpiexec" it correctly states /usr/local/bin/ 
> mpiexec (the mpich2 installed version)
> But when I try the example "mpiexec -n 3 hostname" I get the error  
> message
> -bash: /usr/bin/mpiexec: No such file or directory
> I'm not clear about what's going on here.  Is the python mpiexec in / 
> usr/local/bin trying to call the preexisting mpiexec in /usr/bin?
> The original mpiexec in /usr/bin reports this when run without  
> argument
> mpiexec (OpenRTE) 1.2.3
> <usage/flags snipped>
> Thanks for any help untangling this problem.  I'm not sure why I  
> didn't run into this problem on a new imac that was setup similarly  
> a couple months ago...Perhaps OS preinstalled on that system was an  
> earlier   rev of 10.5.  For whatever reason it does not have any mpi  
> programs in /usr/bin.
> -thomas blom
> ices/ut austin

Jeff Squyres
Cisco Systems

More information about the mpich-discuss mailing list