Rajeev Thakur thakur at mcs.anl.gov
Fri Aug 17 14:11:35 CDT 2007

Yes this looks like a case where a compiler or mpif.h got used from some
other MPI implementation.


> -----Original Message-----
> From: owner-mpich-discuss at mcs.anl.gov 
> [mailto:owner-mpich-discuss at mcs.anl.gov] On Behalf Of Scott Atchley
> Sent: Friday, August 17, 2007 1:11 PM
> To: mpich-discuss at mcs.anl.gov
> Subject: [MPICH] WRF and MPICH2
> Hi all,
> I am trying to run WRF2.1 using MPICH2's ch3:ssm over gigabit  
> Ethernet. When I start the job, I get:
> [cli_0]: aborting job:
> Fatal error in MPI_Comm_size: Invalid communicator, error stack:
> MPI_Comm_size(112): MPI_Comm_size(comm=0x5b, 
> size=0x7fff18349588) failed
> MPI_Comm_size(70).: Invalid communicator
> for each process. I have compiled MPICH2 and WRF with PGI 6.2.6 and  
> 7.0.7 with the same results. If I run it with -gdb, there are no  
> symbols and I cannot debug. I tried compiling MPICH2 with --enable- 
> g=all and then running it with -gdb, but it hangs and never gives me  
> a gdb command line.
> Does anyone have experience with this?
> Thanks,
> Scott

More information about the mpich-discuss mailing list