[MPICH] mpdboot error : fail to ping

Misora Itsumo mitsuru.adachi at gmail.com
Fri Apr 7 17:58:39 CDT 2006

i'm new to MPICH2 and i just installed mpich2 , but i can't make it run on a
set of machines.

i run mpich2 on 2 nodes  , hostnames are hewonty and vm1.
Here are some info

[hewonty at hewonty ~]$ cat mpd.hosts

[hewonty at hewonty ~]$ cat /etc/hosts       localhost.localdomain   localhost     hewonty.homelinux.org   hewonty.vmnet1.org      hewonty     vm1.hewonty.homelinux.org       vm1     svn_server

[hewonty at hewonty ~]$ mpdboot -n 2 -f mpd.hosts
mpdboot_hewonty (handle_mpd_output 359): failed to ping mpd on hewonty;
recvd output={}

i can ssh to hewonty or vm1.

I tried to run mannually by mpd and here are what i got

[hewonty at vm1 ~]$ mpd &
[1] 2056
[hewonty at vm1 ~]$ mpdtrace -l
vm1_32772 (

[hewonty at hewonty ~]$ mpd -h vm1 -p 32772
hewonty_32846: mpd_uncaught_except_tb handling:
  exceptions.TypeError: sequence item 0: expected string, int found
    /usr/local/mpich2/bin/mpdlib.py  627  connect_lhs
        response = md5new(''.join([self.secretword
    /usr/local/mpich2/bin/mpdlib.py  564  enter_ring
    /usr/local/mpich2/bin/mpd  231  run
    /usr/local/mpich2/bin/mpd  1344  ?

Thanks in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/mpich-discuss/attachments/20060408/0738d82e/attachment.htm>

More information about the mpich-discuss mailing list