[AG-TECH] AG3.1 and VIC problems

Douglas Kosovic douglask at itee.uq.edu.au
Mon Mar 3 18:59:37 CST 2008

Hi Mike,

> I've just tried to upgrade my Main AG node from AG3.0.2 to AG3.1
> This is my main node so its configuration is over 3 machines
> Display machine XP, Audio Capture XP, Fedora for video capture. 4
> capture cards (OLD  Hauppage)
> I have the following problems.
> 1. The Node Setup Wizard does not want to start up on the display
> machine. (I tried the audio just to see if its the machine but it also
> freezes)
> 2. If I configure the node via the Client I can configure all the
> machines but the Video Capture defaults to all four feeds coming from
> the same video card. (video3)
> I can then individually configure the cards so that I get all my feeds
> I save the configuration then if I change venues it all defaults back
> just one feed.
> If I configure the card on the fedora machine in the vic menu VIC does
> not appear to save the configuration.
> Anyone seen this this, or have any ideas.

Which Fedora version are you running? If it's Fedora Core 6 or earlier,
make certain you have the latest vic installed (i.e. yum update vic, or
maybe yum install vic). If you have one of the older AccessGrid-vic RPMs
installed, it can't handle the changes introduced with AG 3.1 (so would
most likely end up defaulting to the last videocard /dev/video3). Also
if the VideoProducers are listed as /dev/video0 ... 3 instead of
V4L:/dev/video0 ... 3 (or V4L2:/dev/something), you'll have to delete
the VideoProducers and add them back in.


More information about the ag-tech mailing list