[AG-TECH] long client startuptime

Andrew A Rowley Andrew.Rowley at manchester.ac.uk
Wed Mar 14 04:42:31 CDT 2007


If you are running an AGTk 3.0.1 or earlier bridge, you will find that the "Ping" method is missing.  This means that 3.0.2 clients will resort to trying to ping the bridge directly (i.e. using ICMP ping), which may be the cause of the failure, as many people now block ICMP pings to avoid denial of service attacks; this could be being blocked on either the bridge machine or the client (or both).

Note also that AGTk 3.0.1 or earlier clients won't try to call the "Ping" method at all, and rely entirely on ICMP pings.

Andrew :)

Access Grid Support Centre,
RSS Group,
Manchester Computing,
Kilburn Building,
University of Manchester,
Oxford Road,
M13 9PL, 
Tel: +44(0)161-275 0685
Email: Andrew.Rowley at manchester.ac.uk 
> -----Original Message-----
> From: owner-ag-tech at mcs.anl.gov [mailto:owner-ag-tech at mcs.anl.gov] On
> Behalf Of Ian Frame
> Sent: 13 March 2007 15:50
> To: Kaizaad Bilimorya
> Cc: ag-tech; root at agiraffe.niees.group.cam.ac.uk
> Subject: Re: [AG-TECH] long client startuptime
> Hi,
> We have checked and our firewall is correctly configured. We are not
> denying access to anyone attempting to connect to our bridge (our
> logs confirm this). Have you checked your own firewall is not
> blocking access to us?
> If you reply to me (instead of the list) with information about when
> you tried to connect, and the IP number of the machine you tried to
> connect from, we can look more specifically in our logs for
> information to help solve this problem.
> In the meantime, we have (temporarily) switched off the bridge.
> Regards,
> Ian
> --
> On 13 Mar 2007, at 14:27, Kaizaad Bilimorya wrote:
> > Hello,
> >
> > Is anyone else having trouble with the following bridge causing
> > long startup times (ie: behind a firewall or something)
> >
> > agiraffe.niees.group.cam.ac.uk
> >
> > thanks
> > -k
> >

More information about the ag-tech mailing list