[AG-TECH] building rat for AG3 on ubuntu edgy

Eric Olson eolson at mcs.anl.gov
Thu Mar 8 14:12:26 CST 2007

Hi Brad,

A note on the zsi version.
The zsi 2.0 release had a bug in it.  You can use the zsi 2.0 branch 
until there's another 2.0 release.  Here's the subversion line to check 
out the code:
svn co 

The error you're getting:

 > ImportError: No module named AccessGrid.Toolkit

means python can't find the 3.0 "AccessGrid" or "AccessGrid.Toolkit" 
module(s).  It is likely that your PYTHONPATH is not set correctly.  The 
env-init.sh is supposed to set it.  You can do "echo ${PYTHONPATH}" to 
see what its value is and then correct it.  If you need more help with 
that part, let me know.

Yes, a debian/ubuntu package is definitely needed.  It's been worked on 
but not finished.

If you have any more problems, please send mail.


Brad Langhorst wrote:
> On Thu, 2007-03-08 at 11:19 +1000, Christoph Willing wrote:
>> On 08/03/2007, at 9:02 AM, Brad Langhorst wrote:
>>> I'm having trouble building AG...
>>> using the instructions at
>>> http://www-new.mcs.anl.gov/fl/research/accessgrid/software/cvs- 
>>> instructions.html
> ...
>>> Should I just turn off the warnings?
> thanks... turning off the warnings allowed it to build.
> I also had to upgrade my zsi package from the 1.7 version that comes
> with ubuntu to 2.0 - it was easy to rebuild and repackage using the 1.7
> debian directory.  I also had to change the names in the make file to
> not use .py extensions.
> Then I ran the make services package script like this
>  python makeServicePackages.py  --sourcedir /usr/src/
> --agsourcedir /usr/src/AccessGrid --servicefile servicesToShip 
> , it seemed happy and put a rat and vic in 
> /usr/src/AccessGrid/service/
> According to README-developers, I should now be able to set up my
> environment using the generated init-env.sh and run a node using
> python bin/VenueClient.py --personalNode
> but i get this error: 
> Traceback (most recent call last):
>   File "bin/VenueClient.py", line 27, in ?
>     from AccessGrid.Toolkit import WXGUIApplication,
> MissingDependencyError
> ImportError: No module named AccessGrid.Toolkit
> Is that referring to ag-media?
> I don't find anyting with  
> find AccessGrid/ ag-media/ | grep 'AccessGrid\.Tool'
> What am I missing?
> Brad
> Sigh... wishing for a debian or ubuntu package of AG3

More information about the ag-tech mailing list