[AG-TECH] USB microphones not working in Linux

Anton Gerdelan A.Gerdelan at massey.ac.nz
Wed Jun 6 16:24:30 CDT 2007


I tired switching the program to OSS, I also tried using OSS emulation from 
Linux. I have tried the latest version of RAT also, but no change - the USB 
audio modules will still not work.
I guess this must then require some additional code to interface with them.



On Wednesday 30 May 2007 16:40:25 you wrote:
> Hi Anton,
> > I'm using a ClearOne 50 USB microphone/speaker under Linux.
> >
> > RAT can detect it, but it dosn't interface properly, so it won't work.
> > Under Windows the same microphones work fine.
> In RAT, try switching from ALSA to OSS to see if that helps.
> > Other microphones (3.5mm jack-based) work fine with our Linux AG
> > machines. I've tried this on different Linux flavours (FC6 and Kubuntu
> > E&F) with KDE and Gnome (ALSA and ARTS) and they all have the same
> > problem. I've tried other USB microphones (logitech camera mic) and they
> > don't work either.
> >
> > Would it be helpful if I supplied a log or debug message output? (if so
> > which one?).
> >
> > Any information appreciated,
> With the Fedora 7 AGTk RPMs, I'm now providing a SVN snapshot of UCL RAT
> from the SUMOVER project SVN repository (instead of AG rat). You could try
> installing rat-4.4.00-0.1.20070524svn.fc7.i386.rpm on FC6, the RPM can be
> obtained from:
>    http://www.vislab.uq.edu.au/accessgrid3/fedora/7/i386/
> Alternatively build the Sumover RAT from SVN using these instructions:
>    http://mediatools.cs.ucl.ac.uk/nets/mmedia/wiki/SvnDev
> The new UCL rat might fix your issues.
> Cheers,
> Doug

More information about the ag-tech mailing list