[AG-TECH] 2.3 Toolkit install problem on XP

Jeffrey Bary Jeffrey.Bary at nyu.edu
Tue Sep 21 15:59:34 CDT 2004

The key was to delete all the Python directories after the uninstall. 
I just did the uninstall and the directories were not deleted and the 
install procedure must infer wrongly the proper place for certain 


>On Mon, Sep 20, 2004 at 03:17PM, Jeffrey Bary said:
>>  When I try to start the toolkit from the shortcut on the desktop
>>  nothing happens. The hourglass show for a moment and then it exits.
>>  The debug option produces the same result and no log files are to be
>>  found in C:\Program Files\AGTk-2.3\Logs.
>>  When I run it manually from the command prompt I get this:
>>  C:\DOCUME~1\JEFF\APPLIC~1>C:\Python23\python.exe "C:\Program
>>  Files\AGTk-2.3\bin\
>>  VenueClient.py" -d --personalNode
>>  Traceback (most recent call last):
>>    File "C:\Program Files\AGTk-2.3\bin\VenueClient.py", line 28, in ?
>>      from AccessGrid.Toolkit import WXGUIApplication
>>  ImportError: No module named Toolkit
>on my first XP install of 2.3 i was in a hurry and distracted and got a
>python error that wasn't the same as yours, but similar.  some Python
>script that was in the XXX/site_packages/AccessGrid/ wasn't being located
>causing VenueClient.py to bail.
>i de-installed more carefully (removing Python23 directory after uninstall)
>and re-installed more carefully.  problem solved.

More information about the ag-tech mailing list