[AG-TECH] AGtk2.3 Gentoo Questions (and answers???)

Rhys Hawkins Rhys.Hawkins at anu.edu.au
Sun Oct 31 22:30:24 CST 2004


I've just got AGtk 2.3 going on Gentoo and had to solve a number
of issues:

1. Compilation of VIC failing due to pthread_equal symbol missing
(A couple of other people have had the same problem, is there a
solution yet?):

This (I think) is due to the auto[conf|make|tools] being a little
old and not recognising the --host flag that ebuild script gives
it from the make.conf file. This in turn causes the configure
scripts not to be able work out how to make/link with dynamic
libraries so it reverts to static linking which doesn't work 
properly. The workaround to get past this (which worked for me)
was to modify the ebuild script and manually set the host:

38:    cp ${FILESDIR}/vic-1.1.3-config.sub config.sub
39:    EXTRA_ECONF="`use_enable debug` --host=i686-unknown-linux"
40:    econf || die "Failed to configure vic"
41:    emake || die "Failed to make vic"

Note, my CHOST="i686-pc-linux-gnu" (from /etc/make.conf)

2. Downloading agtk-2.3.tar.gz failed:

On closer examination the md5 hash and file sizes were different
to what was reported in
"/usr/local/portage/ag-libs/agtk/files/digest-agtk-2.3".  I'm
assuming the source tar gz recently got updated and someone forgot to
update the hashes/file sizes in the gentoo package. Can someone
_please_ confirm this for me. I updated the above file to match the
source tgz that was downloaded (all the while hoping that anl 
hadn't been hacked and the agtk source trojan'd) and emerging
worked from then on.

3. Python exception:

I get the following error when running agpm.py --post-install:

Traceback (most recent call last):
  File "/usr/bin/agpm.py", line 445, in ?
  File "/usr/bin/agpm.py", line 303, in main
    tkConf = AGTkConfig.instance()
line 65, in instance
line 94, in __init__
line 100, in _Initialize
line 209, in GetSharedAppDir
    raise Exception, "AGTkConfig: app dir does not exist."
Exception: AGTkConfig: app dir does not exist.

I fixed this by creating the /etc/AccessGrid/SharedApplications dir.

Not the smoothest install I've ever done, but the AGtk 2.3 now
works on my gentoo box.


More information about the ag-tech mailing list