[Fwd: Re: [AG-TECH] Building AG-2.3 for Mandrake 10.X]

Steven Woolsey woolsr at inel.gov
Thu Nov 18 14:53:29 CST 2004

Forgot to cc the list.  sorry.

-------- Original Message --------
Subject: 	Re: [AG-TECH] Building AG-2.3 for Mandrake 10.X
Date: 	Thu, 18 Nov 2004 13:51:53 -0700
From: 	Steven Woolsey <woolsr at inel.gov>
To: 	Eric Olson <eolson at mcs.anl.gov>
References: 	<419BA517.5080804 at inel.gov> 
<Pine.LNX.4.58.0411171446580.9920 at terra.mcs.anl.gov> 
<419BC32E.1070808 at inel.gov> 
<Pine.LNX.4.58.0411171546390.9920 at terra.mcs.anl.gov>


Thank you for the suggestions.  I have tried them, and these are the 

I have looked for the file
but none exists.  The file .aglog file in /tmp doesn't exist either.
Any other suggestions?


I tried the -cert and -key option with -debug.  Here are the results:

   [woolsr at aesir woolsr]$ grid-proxy-init -cert cert2.pem -key key2.pem 

   User Cert File: cert2.pem
   User Key File: key2.pem

   Trusted CA Cert Dir: (null)

   Output File: /tmp/x509up_u501
   Your identity: /O=Access 
Grid/OU=agdev-ca.mcs.anl.gov/OU=inel.gov/CN=Steven Woolsey
   Enter GRID pass phrase for this identity:

   ERROR: Couldn't read user key: Bad passphrase
   key file location: key2.pem

   globus_gsi_credential.c:1092: globus_gsi_cred_read_key: Error 
reading user credential: Can't
    read credential's private key from PEM
   OpenSSL Error: pem_lib.c:455: in library: PEM routines, function 
PEM_do_header: bad decrypt
   OpenSSL Error: evp_enc.c:277: in library: digital envelope routines, 
function EVP_DecryptFinal: bad decrypt
   OpenSSL Error: pem_lib.c:666: in library: PEM routines, function 
PEM_read_bio: no start line

I am not sure what all of that means.
I tried an Anonymous Certificate and set it to the default, but the 
grid-proxy-init still couldn't find it, so I used certmgr.py to export 
the cert and key.  Using the -cert and -key worked with the anonymous 
certificate.  So it appears to be something with the keys I have 
imported.  I requested a new key from this machine, and it still won't 
accept my passphrase.



Eric Olson wrote:

>Good to hear there's some improvement.  Here are a couple suggestions.
>32 bit:
>The AGServiceManager log file is normally in 
>  ~/.AccessGrid/Logs/AGServiceManager.log
>but if there's an error before initialization, you might find information 
>in a .aglog file in /tmp.
>It looks like there's an exception calling AGTkConfig.instance(0) in 
>Toolkit.py.  If you want to debug that call, note that the AGTkConfig 
>class being used is defined in Platform/unix/Config.py.
>It could be that the necessary toolkit directories don't exist -- they are 
>usually created at install time or with CvsSetup.py:
>  python tools/CvsSetup.py -a .
>  . env-init.sh
>64 bit:
>  I'm not sure what the real problem is, but if you use grid-proxy-init 
>with -cert and -key options and the certificate files you exported, you 
>should be able to tell if there is a problem with your globus environment.
>  If that works, trying an anonymous certificate from within the AG 
>Toolkit is another good (and quick) test.

Steven Woolsey
woolsr at inel.gov
Senior Engineer/Scientist
Visualization Engineer

Steven Woolsey
woolsr at inel.gov
Senior Engineer/Scientist
Visualization Engineer

More information about the ag-tech mailing list