[AG-TECH] Building AG-2.3 for Mandrake 10.X

Steven Woolsey woolsr at inel.gov
Wed Nov 17 15:31:26 CST 2004


Thanks for your reply.

pyGlobus is installed, but it looks like there is something missing.  
When I tried the last import line at a python prompt:

from pyGlobus.io import GSITCPSocketServer, ThreadingGSITCPSocketServer

python said it couldn't find one of the globus libraries: 
libglobus_io_gcc32dbgpthr.so.0.  Looking for that file, I realized that 
I had built globus for gcc32pthr instead of gcc32dbgpthr, so the 
filename it was looking for was not there.  I must have messed up with 
my last compile of globus.  I recompiled globus and no longer get that 

I do have another couple of issues now, but it is different on 32 bit 
versus 64 bit.

32 bit: I run the AGServiceManager.py and get the following error:

    Toolkit Initialization failed, exiting.
     Initialization Error:  -1

I tried looking in the .AccessGrid directory, but am unsure what logs to 
look at.  Which log should I look at to find the problem?

64 bit:

The scripts are running, but it appears that something is wrong with the 
certificates.  I exported my certificate from the 32 bit machine and put 
it on the 64 bit one.  Importing worked fine, but now when I try to 
start a proxy it tells me my pass phrase is invalid.  Trying 
'grid-proxy-init -debug'  tells me:

    ERROR: Couldn't find valid credentials to generate a proxy.

        Error with certificate filename: The user cert could not be 
found in:
    1) env. var. X509_USER_CERT=NULL
    2) /home/woolsr/.globus/usercert.pem
    3) /home/woolsr/.globus/usercred.p12

Any ideas?



Eric Olson wrote:

>Hi Steven,
>It looks like a pyGlobus installation is missing.  Can you make sure 
>you've built and installed pyGlobus (and globus)?  It looks like you need 
>pyGlobus in /usr/lib64/python2.3/site-packages.
>On Wed, 17 Nov 2004, Steven Woolsey wrote:
>>I am currently trying to get a working build of AG 2.3 to work under 
>>mandrake 10.x for both 32 bit and x86_64.  I have most of the packages 
>>built, but when I try to start the AGServiceManager I get the following 
>>Traceback (most recent call last):
>>  File "/usr/bin/AGServiceManager.py", line 23, in ?
>>    from AccessGrid.hosting import SecureServer
>>  File 
>>line 120, in ?
>>    SetHostingImpl(__hostingImpl)
>>  File 
>>line 62, in SetHostingImpl
>>    s = __import__(nis, globals(), locals(), ["SecureServer",
>>  File 
>>line 20, in ?
>>    from SOAPpy.GSIServer import ThreadingGSISOAPServer, GSIConfig
>>  File "/usr/lib64/python2.3/site-packages/SOAPpy/GSIServer.py", line 
>>74, in ?
>>    from pyGlobus.io import GSITCPSocketServer, ThreadingGSITCPSocketServer
>>ImportError: cannot import name GSITCPSocketServer
>>Obviously I am missing something.  Does anyone have any suggestions of 
>>what I might look at to resolve these problems?

Steven Woolsey
woolsr at inel.gov
Senior Engineer/Scientist
Visualization Engineer

More information about the ag-tech mailing list