[AG-TECH] BridgeServer trouble

Michael Braitmaier braitmaier at hlrs.de
Mon Nov 15 08:01:19 CST 2004

Please see below!

----- Original Message ----- 
From: "Christoph Willing" <willing at itee.uq.edu.au>
To: "Michael Braitmaier" <braitmaier at hlrs.de>
Cc: "West Suhanic" <wsuhanic at alumni.uwaterloo.ca>; "Thomas D. Uram" 
<turam at mcs.anl.gov>; <ag-tech at mcs.anl.gov>
Sent: Monday, November 15, 2004 1:54 PM
Subject: Re: [AG-TECH] BridgeServer trouble

> On 15/11/2004, at 7:36 PM, Michael Braitmaier wrote:
>> HEllo chris!
>> I am using a quite small port range with our bridgeserver here at our 
>> institute, only allowing a port range of 4 ports, which is exactly  what 
>> is needed to bridge one room. For example:
>> #HLRS AG Room on ANL Server
>> [https://hume.mcs.anl.gov:9000/Venues/ 
>> 000000f5569d3f0a008c00dd000b003761b]
>> type=Venue
>> portMin=50096
>> portMax=50099
>> Two ports are allocated for audio (in/out) and two ports are allocated 
>> for video (in/out).
>> Works quite stable.
> Michael,
> Since you had success, I just tried mine again and it worked fine.
> I did do one thing differently and this seems to be significant. My 
> original port number range was portMin=24000, portMax 24004 ( they were 
> just commented out in the bridge.conf file). I changed them to 24000 & 
> 24003 and it worked perfectly. When I changed back to the original  24000 
> & 24004, I had errors again,namely:
>     can't bind ucaddr to socket!: Address already in use

That is related to something different. The port allocator code uses a 
random port allocation method. I changed the code of my AccessGrid 
installation, to have a repeatable intervall allocation of ports.This means 
everytime I start the bridge the ports will be allocated starting with 
<PortMin> and ending with <PortMax>.
The normal AG distribution uses a random number generator to allocate the 
ports so it is possible that one uc-port might be used for different 
mc-ports, due to a bug (i guess) in the portallocator python script, which I 
also fixed to have a stable track of ports already used.


> When I changed back to 24000 & 24003 and problem disappeared. So its 
> working now, but I think something is still not quite perfect in the  port 
> allocation.
> So West, thats something else you could try: I see that your port range 
> was 24000-24006. What happens if you try portMin=24000 and  portMax=24003?
> chris
> Christoph Willing                        Ph: +61 7 3365 8350
> QPSF Access Grid Manager
> University of Queensland

More information about the ag-tech mailing list