[AG-TECH] Problem Managing Node

Jason Bell j.bell at cqu.edu.au
Wed Apr 7 18:14:05 CDT 2004

G'day Mike

I experienced the same problem myself.  What I found was when I viewed
my "Trusted CA Certificates" the Access Grid Developers certificate was
missing and I could nothing to obtain a new one. 

Unlike yourself, I was importing a previously saved "Identity
Certificate", but I was obtaining the same result.

Now, I never had this problem when I was using RedHat 9.0. using an
older version of the AG2 software.  How I overcame this problem was
renaming the .AccessGrid folder and "copying" a previously saved
.AccessGrid folder which then the system appeared to work fine.

I am still in the Process of getting everything up and running nicely on
Fedora and if you have any other additional questions, please don't
hesitate to contact me.

I must also thank Douglas (University of Queensland) who was a great
help in helping me fix this problem.

I hope I was of some help,

Jason Bell, B.I.T.
B. Info. Tech. (Honours) Student

Network Engineer
Information Technology Division
Central Queensland University

High Performance Computing Support Officer
Central Queensland University

Research Assistant to the Nonlinear Intelligent Systems Research Group
Faculty of Informatics & Communication
Central Queensland University

E-mail : j.bell at cqu.edu.au
Phone : 07 4930 9229


Patience is a virtue.
But if I wanted Patience,

I would have become a Doctor.

-----Original Message-----
From: Mike Weaver [mailto:weaver at er.doe.gov] 
Sent: Thursday, 8 April 2004 02:14
To: ag-tech at mcs.anl.gov
Subject: [AG-TECH] Problem Managing Node

Hi all,

I just built AG2 on a Fedora Core system using University of
Queensland's RPMs.  Got my Identity certificate and brought up the
VenueClient.  This worked fine.  When I go to Node Management and enter
the default URL which resolves to https://localhost:12000/NodeService, I
get "Can not open node service management based on the URL you

AGNodeService.py, AGServiceManager.py & VenueClient.py are all running,
seemingly successfully.  I've attached the agns.log and VenueClient.log
from a debug session.  I don't see anything too unusual.  I see the code
to raise an exception in AGNodeService.py, but don't know why it's being

Might this be a certificate problem?  I originally requested a new
certificate using the AGTk while running as root.  When I fired up the
VenueClient in presonalNode mode (simplest for now, I have other
machines, but one thing at a time), it complained that it wanted to be
run by an ordinary user.  Running as a user didn't see the original cert
request, so I ran certmgr.py as root and exported the id cert and used
the VenueClient to import it.  This seemed successful.  The one thing
that I notice is running certmgr.py as either root or an ordinary user
(or even accessing the certs from the VenueClient), I don't see any CA
certs listed.  Is this correct?  Should I not have installed the AG
packages as root?  Something else?

Any advice, would be appreciated,


Mike Weaver
Sr. Network Administrator
SC-31/Germantown Building
US Department of Energy
1000 Independence Avenue, SW
Washington, D.C. 20585-1290
Voice: 301-903-0072
Fax: 301-528-2701
Email: weaver at er.doe.gov

More information about the ag-tech mailing list