[AG-TECH] Problem Managing Node

Mike Weaver weaver at er.doe.gov
Wed Apr 7 14:01:49 CDT 2004

Well, I'm now pretty well convinced that it is certificate-related.  I
installed and configured AG2 on a WinXP box and see both the Globus &
ANL CA certs.  Node management works and I can navigate around the ANL

So, I exported the 2 CA certs and tried to import them into the Fedora
machine, but it complains that it needs the signing_policy file for each
CA.  How do I go about getting these?  Is there something fundamentally
wrong here?  Aren't the Globus & ANL CA certs pre-installed in the AGTk
software?  Should I try re-installing the Fedora-specific RPMs?



----- Original Message ----- 
From: "Mike Weaver" <weaver at er.doe.gov>
To: <ag-tech at mcs.anl.gov>
Sent: Wednesday, April 07, 2004 12:14
Subject: [AG-TECH] Problem Managing Node

> Hi all,
> I just built AG2 on a Fedora Core system using University of
> Queensland's RPMs.  Got my Identity certificate and brought up the
> VenueClient.  This worked fine.  When I go to Node Management and
> the default URL which resolves to https://localhost:12000/NodeService,
> get "Can not open node service management based on the URL you
> specified".
> AGNodeService.py, AGServiceManager.py & VenueClient.py are all
> seemingly successfully.  I've attached the agns.log and
> from a debug session.  I don't see anything too unusual.  I see the
> to raise an exception in AGNodeService.py, but don't know why it's
> raised.
> Might this be a certificate problem?  I originally requested a new
> certificate using the AGTk while running as root.  When I fired up the
> VenueClient in presonalNode mode (simplest for now, I have other
> machines, but one thing at a time), it complained that it wanted to be
> run by an ordinary user.  Running as a user didn't see the original
> request, so I ran certmgr.py as root and exported the id cert and used
> the VenueClient to import it.  This seemed successful.  The one thing
> that I notice is running certmgr.py as either root or an ordinary user
> (or even accessing the certs from the VenueClient), I don't see any CA
> certs listed.  Is this correct?  Should I not have installed the AG
> packages as root?  Something else?
> Any advice, would be appreciated,
> Mike
> --
> Mike Weaver
> Sr. Network Administrator
> SC-31/Germantown Building
> US Department of Energy
> 1000 Independence Avenue, SW
> Washington, D.C. 20585-1290
> Voice: 301-903-0072
> Fax: 301-528-2701
> Email: weaver at er.doe.gov

More information about the ag-tech mailing list