[AG-TECH] reflector library error

Gary Refka grefka at insors.com
Tue Aug 21 10:30:19 CDT 2001


I ran into the same error doing the same thing.  I ended up pointing the
libtk8.0.so at the libtk8.3.so.  You could also do this by renaming the
.3.so to .0.so.  In any case it functioned fine after the change.

Gary A. Refka
Senior Sales Engineer
INSORS Integrated Communications, Inc.
111 W. Jackson Blvd., Suite 1412
Chicago, IL 60604
Email: grefka at insors.com
On the Web: www.insors.com

-----Original Message-----
From: owner-ag-tech at mcs.anl.gov [mailto:owner-ag-tech at mcs.anl.gov]On
Behalf Of Wesley Lau (DSD student -DAA)
Sent: Monday, August 20, 2001 8:20 PM
To: ag-tech at mcs.anl.gov
Subject: [AG-TECH] reflector library error


I'm running RH7.1 and am having a problem with running the reflector.  I
get the following error message when trying to run it:

[ag at agpbvid bin]$ reflector 10000 10001
reflector: error while loading shared libraries: libtk8.0.so: cannot load
shared object file: No such file or directory
[ag at agpbvid bin]$

I have /usr/lib/libtk8.3.so installed, and I prefer not to downgrade.  Is
there a way to get reflector to ignore the version number.  When
installing the reflector rpm, it complained about the same library, but I
used the --nodeps option to force the install.


More information about the ag-tech mailing list