[petsc-users] Libraries destination directory is non-standard

Juan Luis Cano juanlu001 at gmail.com
Thu Jan 8 14:32:22 CST 2015

Hello all,

I am trying to build a conda package of PETSc 3.4 using its Python build 
system so anybody can install it in the Anaconda Python distribution. I 
need PETSc as a dependency for FEniCS.

The problem is that the required shared libraries (also those 
corresponding to external packages such as UMFPACK) are installed in 
$PREFIX/lib/python2.7/site-packages/petsc/lib. The build process goes 
perfectly fine but when packaging this into a tarball these libs won't 
be found by any package as they are not in $PREFIX/lib. Here is the 
build script I am using:


I tried to change the destination using `--prefix` in 
PETSC_CONFIGURE_OPTIONS and after `setup.py install`, but neither 
worked. Changing LD_LIBRARY_PATH seems dangerous to me and creating 
symbolic links three levels higher seems dirty. If the python version 
changes, or "lib64" is added somewhere, this will surely break... Does 
anybody have a suggestion on how to do this?

Thanks in advance, regards,

Juan Luis

More information about the petsc-users mailing list