[petsc-users] Help with mpiexec

George Mathew gmnnus at gmail.com
Sat Oct 13 14:17:04 CDT 2012

I have petsc 3.3 and mpich2 version 1.4.1p1 installed.
When I run the example ex2.c code in the petsc user manual, it runs one one
machine format. But, if I chose to run on multiple nodes, it gives error.
The example is the file ${PETSC}/src/ksp/ksp/examples/tutorials/ex2.c.
I compiled it and when run using the following command, it works.
mpiexec -f machinefile -n 1 ./ex2
But, if I run it using the command
mpiexec -f machinefile -n 2 ./ex2
I get the following error.

[0]PETSC ERROR: PetscOptionsInsertFile() line 485 in
[0]PETSC ERROR: PetscOptionsInsert() line 621 in src/sys/objects/options.c
[0]PETSC ERROR: PetscInitialize() line 751 in src/sys/objects/pinit.c
PETSC ERROR: Logging has not been enabled.
You might have forgotten to call PetscInitialize().
application called MPI_Abort(MPI_COMM_WORLD, 56) - process 0

Can anyone help? Thanx in advance.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-users/attachments/20121013/e49bad77/attachment.html>

More information about the petsc-users mailing list