[petsc-users] Need help...

jean-frederic thebault jean-frederic at thebault-net.com
Tue Nov 8 10:09:00 CST 2011


First of all, thank you for this library.
View years ago, we had mixed our (f77) finite volume code with petsc, and
obtained some very interested results (faster calculations, multi-processor
issues, ..), with a 4 linux-PC cluster and a myrinet switch, and petsc-2.1.3
Regarding the new PC architecture (multi-threading), the same mixed code
apparently is calculating slower each time we increase the number of
processors used (processor or core, I'm not sure to use the right word). We
thought that time that we should upgrade our petsc library (with
petsc-3.1-p8) to have benefit of the multi-threading architecture. So do
we, changing a little bit some stuff (merrely "include" names). We compiled
it with mpif77. The fortran-samples of petsc are working just fine. But our
code doesn't work. We have tried a lot of different options and tried for
view weeks to figure out what is happening, nothing.
I really would like some help in that matter because I don't see where is
the problem. I'm wondering if you could, reading the out.log, tell me where
I should investigate the problem ? (kind of ? out of array definition or
other ? ) I really don't see and if you could please help me, I would
really appreciate it !!
I put the out.log in this email

Many Thanks.
Best Regards.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mcs.anl.gov/pipermail/petsc-users/attachments/20111108/f3b9872b/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: out.log
Type: application/octet-stream
Size: 8583 bytes
Desc: not available
URL: <http://lists.mcs.anl.gov/pipermail/petsc-users/attachments/20111108/f3b9872b/attachment.obj>

More information about the petsc-users mailing list