Version of Mpi and fblaslapack

Barry Smith bsmith at
Fri Oct 12 12:41:32 CDT 2007

  You are totally misunderstanding the situation! PETSc should work with
virtually ANY release of gcc or other C or C++ compiler and ANY mpicc
and mpif77 unless they have bugs or are not installed properly.

  The point is you can not mix incompatible compilers or MPIs when
you install two or more different packages to work together. This has nothing to 
do with PETSc. If you build Diffpack and Superlu_dist with different MPI's
it would not work.


On Fri, 12 Oct 2007, Trivedi, Jagruti CIV 470000D, 474300D wrote:

> Satish,
> That is not the point. The question is how to find out which version of
> compilers such as gcc(or c ) , C++ mpicc , mpif77 is needed for petsc
> 2.2.1, 2.3.0, 2.3.2 etc?
> I do not want to find out after the fact that oh I needed so and so
> compiler version.
> If possible, can this information be listed as part of Release Notes? If
> this information is already available, can you point me to the right
> place.
> Thanks,
> ...Jagruti 
> -----Original Message-----
> From: owner-petsc-users at
> [mailto:owner-petsc-users at] On Behalf Of Satish Balay
> Sent: Friday, October 12, 2007 7:23
> To: petsc-users at
> Subject: Re: Version of Mpi and fblaslapack
> On Fri, 12 Oct 2007, Mads Hoel wrote:
> > 
> > I found out that linking PETSc with another library (Diffpack) 
> > compiled with different versions of MPI will crash when calling 
> > InitializePetsc(...). My solution was to drop running config/configure
> > with --download-mpi option, but have MPI point to the correct 
> > installation of MPI using the --with-mpi-dir=/path/to/mpi option.
> Yes - you cannot mix 2 different versions of MPI [or any other package]
> to create a single binary. This is equvalent to using include files from
> package-version1 - and linking with package-version2. [which is
> obviously wrong.]
> In the same way, its best to install ALL packages that go into a binary
> with the same compiler set [c,c++,fortran].
> Usually compilers & MPI are the basic blocks that many external packages
> use, so in this case one can first install MPI [with the correct desired
> compilers]. And then install all other packages [used by the
> application] with the MPI wrappers.
> And all external packages built by PETSc will use the compilers/MPI
> specified to PETSc.
> ./config/ --with-cc=mpicc --with-fc=mpif90 or the shortcut
> equivalent of the above:
> ./config/ --with-mpi-dir=
> Satish

More information about the petsc-users mailing list