understanding the output from -info

Satish Balay balay at mcs.anl.gov
Sun Feb 11 21:41:29 CST 2007

- If you have build isses [involing sending configure.log] please use
petsc-maint at mcs.anl.gov address [not the mailing list]

- Looks like you were using the following configure options:

--with-mpi=0 --with-x=0 --with-shared

But now - you are not specifing the compilers. The default compiler in
your path must be Intel compilers version 7. Configure breaks with it.
So sugest using the compilers that worked for you before. i.e


If you still have problem with hypre - remove
externalpackages/hypre-1.11.1b and retry.


On Mon, 12 Feb 2007, Ben Tay wrote:

> Hi,
> I tried to compile PETSc again and using --download-hypre=1. My command
> given is
> ./config/configure.py --with-vendor-compilers=intel
> --with-blas-lapack-dir=/lsftmp/g0306332/inter/mkl/ --wit
> h-x=0 --with-shared --with-mpi-dir=/opt/mpich/myrinet/intel/
> --with-debugging=0 --download-hypre=1
> I tried twice and the same error msg appears:
> Downloaded hypre could not be used. Please check install in
> /nas/lsftmp/g0306332/petsc-2.3.2-p8/externalpackages/hypre-1.11.1b/linux-hypre.
> I've attached the configure.log for your reference.
> Thank you.

More information about the petsc-users mailing list