[petsc-dev] Need a new name for DMDAGetOwnershipRanges
bsmith at mcs.anl.gov
Mon Nov 29 16:34:07 CST 2010
On Nov 29, 2010, at 4:23 PM, Jed Brown wrote:
> On Mon, Nov 29, 2010 at 23:21, Barry Smith <bsmith at mcs.anl.gov> wrote:
> Crap. That means that the output from this newly modifed function is not what is needed by the creation routine. In fact there exists DMDASetOwnershipRanges(). What are we going to do with that? Change the meaning of DMDASetOwnershipRanges() arguments (and hence also the meaning of the final optional arguments to the DMDACreate3d() and 2d)? For uniformaty we need to change those also. But the changed form is more cumbersome and less natural for users, is it not? Or is it ok to change all of them? We don't have a concept of setting global ownership values for Vec and Mat (cause the meaning is a little different). Maybe a name change is in order?
> That was my original thought, either change the meaning of all these things or change the name.
Then why didn't you say that? Your original email didn't make clear that lots of PETSc code needed to be changed (to perhaps a more cumbersome model). When I thought basically it was only user code that needed much change I was perfectly happy to make them change it, but now that it involves PETSc code I'm not so sure :-)
BUT given my hatred of new concepts and the fact that it basically fits the VecGetOwnershipRanges() concept I still think the correct fix is to change all the PETSc code but leave the same names. Never introduce a new concept to save changing code, only introduce a new concept when it is really needed and here it is not really needed!
More information about the petsc-dev