[mpich-discuss] Reading files in parallel in winxp with mpich2

Jayesh Krishna jayesh at mcs.anl.gov
Mon Aug 22 11:15:10 CDT 2011

 Are you using MPI-IO (MPI_File_open()...)? You should make sure that all MPI processes have access to the file (MPICH2 on Windows does not perform automatic file staging).


----- Original Message -----
From: "TAY wee-beng" <zonexo at gmail.com>
To: mpich-discuss at mcs.anl.gov
Sent: Thursday, August 18, 2011 1:57:09 PM
Subject: [mpich-discuss] Reading files in parallel in winxp with mpich2


I am running winxp under virtualbox.

I managed to run my mpi code compiled using compaq visual fortran in winxp.

I run it with wmpiexec with 1-8 processors and it worked fine.

However when my mpi code requires reading in of files, it worked only if 
I use 1 processor.

For more than 1 processor, I got the file not found error.

How can I solved this error? Btw, when using wmpiconfig, I only get 1 host.

Thank you very much!

Yours sincerely,

TAY wee-beng

mpich-discuss mailing list
mpich-discuss at mcs.anl.gov

More information about the mpich-discuss mailing list